مشورے درخواستیں اور شکایات

ابن سعید نے 'روبی آن ریلز' کی ذیل میں اس موضوع کا آغاز کیا، ‏جنوری 25, 2009

  1. ابن سعید

    ابن سعید خادم

    مراسلے:
    60,116
    آن لائن کورسیز فورم کو صاف ستھرا رکھنے کی کوشش کی گئی ہے تاکہ بعد میں یہاں آنے والوں کو کم سے کم تلاش سے زیادہ سے زیادہ کار آمد مواد حاصل ہو سکے۔ اسی سلسلے میں ایک قدم یہ اٹھایا گیا ہے کہ دھاگے شروع کرنے کے اختیارات محدود کر دیے گئے ہیں۔ لہٰذا ایسی کسی ضرورت پر آپ اس کے لئے یہاں درخواست دے سکتے ہیں۔

    اس کے علاوہ بھی ہر قسم کے مشورے درخواستیں اور شکایات جو یہاں کرنا موزوں ہوں ان کے لئے یہ دھاگہ استعمال کیا جائے۔

    والسلام
     
  2. اظفر

    اظفر محفلین

    مراسلے:
    782
    جھنڈا:
    Pakistan
    موڈ:
    Busy
    السلام علیکم
    سعود بھائی یہ تو بتا دیں‌ کہ روبی ن ریلز کو کون سا ورژن اور کہاں سے ڈاون لوڈ کرنا ہے ۔
     
    • پسندیدہ پسندیدہ × 2
  3. نبیل

    نبیل محفلین

    مراسلے:
    16,612
    جھنڈا:
    Germany
    موڈ:
    Depressed
    اس فورم کی سیٹنگ میں کچھ مسئلہ تھا جس کی وجہ سے نئی پوسٹس موڈریشن کیو میں لگ جاتی تھیں۔ اسے میں نے ٹھیک کر دیا ہے۔
     
    • پسندیدہ پسندیدہ × 2
  4. ابن سعید

    ابن سعید خادم

    مراسلے:
    60,116
    اظفر بھائی بغیر یہ بتائے کورس کی شروعات کیسے ہو گی بھلا۔ :) بس ذرا سا توقف کریں ابھی ہم چیزوں کو سنجو رہے ہیں۔ کل شام تک یہاں کافی کچھ ہو گا ان شاء اللہ شروعات کرنے کے لئے۔ ویسے آپ کے سوال کا مختصر سا جواب یہ ہے تازہ ترین اسٹیبل ورژن استعمال کیا جائے گا جو کہ 2۔2۔2 ہے۔ اسے حاصل کرنے کے لئے گوگل کر لیں تو اور بھی کئی اضافی معلومات مل جائیں گی۔ ورنہ میں تو بتاؤں گا ہی۔
     
    • پسندیدہ پسندیدہ × 4
  5. باذوق

    باذوق محفلین

    مراسلے:
    1,093
    روبی آن ریلز کے تعارف اور کورس درخواست طلبی پر مبنی کچھ عرصہ قبل جو دھاگہ/دھاگے کھولے گئے تھے ، اگر وہ بھی یہیں اسی فورم میں منتقل کر دئے جائیں‌ تو بہتر رہے گا۔
     
    • پسندیدہ پسندیدہ × 1
  6. اظفر

    اظفر محفلین

    مراسلے:
    782
    جھنڈا:
    Pakistan
    موڈ:
    Busy
    جی مل گیا مگر انہوں نے لکھا ہے
    We recommend Ruby 1.8.7 for use with Rails. Ruby 1.8.6, 1.8.5, 1.8.4 and 1.8.2 are still usable too, but version 1.8.3 is not.

    2۔2۔2 ان کی ویب سایٹ پر ہے نہیں یا مجھے نہیں مل رہا۔
    انہوں نے پہلے صفحہ پر 2۔2 ہی لکھا ہوا ہے۔ خیر جو موجود تھا وہی اتار لیا ہے میں اس وقت۔
    البتہ ریلز کا ورژن 2۔2 ہی ہے
    دونوں کو اتارنے کیلیے ربط یہ ہیں

    روبی
    ریلز
     
    • پسندیدہ پسندیدہ × 2
  7. ابن سعید

    ابن سعید خادم

    مراسلے:
    60,116
    بھئی میں نے ریلز کا ہی ورژن بتایا تھا۔

    ویسے ونڈوز پر ریلس سیٹ اپ کے لئے مجھے یہ لنک ملا ہے۔

    اگر آپ احباب میں سے کوئی اپنے تجربات اسکرین پرنٹ کے سہارے محفوظ کر کے فراہم کر سکیں تو مجھے سہولت ہو جائے گی۔ ورنہ مجھے ونڈوز کی طرف جانا پڑ جائے گا۔
     
  8. ابن سعید

    ابن سعید خادم

    مراسلے:
    60,116
    باذوق بھائی مشورے کا شکریہ۔

    ان میں سے بعض کو یہاں لایا جا سکتا جبکہ کچھ اپنی جگہوں پر زیادہ موزوں ہیں۔ ان شاء اللہ یہ کام بھی عمل میں آ جائے گا۔ فی الحال یہ ترجیحی نہیں ہے۔ مجھے جلدی ہی آپ لوگوں کو بھری پری خوراک دینی ہے۔ :fingers-crossed:
     
  9. اظفر

    اظفر محفلین

    مراسلے:
    782
    جھنڈا:
    Pakistan
    موڈ:
    Busy
    سعود برادر اس بات کی سمجھ نہیں لگی ۔ کیا کہنا چاہ رہے ہیں آپ۔
     
    • پسندیدہ پسندیدہ × 1
  10. ابن سعید

    ابن سعید خادم

    مراسلے:
    60,116
    بھئی میں یہ کہنا چاہ رہا تھا کہ انسٹالیشن میں جو جو اسٹیپس فالو کریں اس کو رکارڈ کرتے جائیں تاکہ دوسرے اس کا فائدہ اٹھا سکیں۔ اب میرے ساتھ مسئلہ یہ ہے کہ میں لینکس یوزر ہوں اور ونڈوز بہت کم کئی مہینوں میں ایک آدھ بار استعمال کرتا ہوں۔ تو میرے لئے سیٹ اپ پروسیجر تیار کرنا ذرا مشکل امر ہوگا۔

    اگر آپ اب بھی میری بات نہ سمجھ سکے ہوں تو مزید وضاحت کروں۔
     
    • پسندیدہ پسندیدہ × 1
  11. نبیل

    نبیل محفلین

    مراسلے:
    16,612
    جھنڈا:
    Germany
    موڈ:
    Depressed
    ابن سعید، میں نے RoR کا پرانا ورژن انسٹال کیا ہوا ہے۔ کیا روبی اور ریلز کا نیا ورژن انسٹال کرنا ضروری ہے۔ کیا اس کے لیے پرانا ورژن ان انسٹال کرنا پڑے گا۔
     
    • پسندیدہ پسندیدہ × 1
  12. ابن سعید

    ابن سعید خادم

    مراسلے:
    60,116
    نبیل بھائی اگر ریلس کا 2۔2 ورژن استعمال کریں تو زیادہ بہتر ہوگا کیوں کہ اس میں ان بلٹ لوکلائزیشن کے فیچر دستیاب ہیں۔ جن پر کم از کم ایک ہفتہ صرف کرنے کا ارادہ رکھتا ہوں۔ ویسے ریلس 2 کا کوئی بھی ورژن ہو تو چلے گا۔ در اصل بیک وقت کئی سارے ورژن بھی استعمال کر سکتے ہیں۔ اس کا طریقہ یہ ہے کہ سسٹم میں موجود انسٹالیشن میں سے کسی ایپلیکشن کے لئے کون سا ورژن استعمال ہو اس بات کا تعین ایک کنفیگیوریشن فائل میں جیم ورژن اسپیسفائی کرنے سے ہو جاتا ہے۔ یہ فیچر خاص کر بیک ورڈ کمپیٹبلٹی کے لئے استعمال کیا جاتا ہے تاکہ کوئی ڈیپلائڈ ایپلیکیشن انکمپیٹبلٹی کا شکار نہ ہو جائے۔

    آپ gem update --system کمانڈ دے کر دیکھیں ان شاء اللہ سارے پیکیج از خود اپڈیٹ ہو جائیں گے۔ویسے میرا مشورہ یہ ہوگا کہ ایک عدد ورچؤل مشین انسٹال کر لیجئے اور اس میں لینکس چلا لیجئے۔ کیوں کہ ریلس ونڈوز میں ڈیویلپرس کی پسند نہیں اس لئے اصلی مزہ تو اسی انوائرنمینٹ میں آنا ہے۔ آپ کو لینکس کی مکمل انسٹالیشن کی طرف جانے کا مشورہ اس لئے نہیں دے سکتا کیوں کہ آپ کے دوسرے کام متاثر ہونگے۔
     
    • پسندیدہ پسندیدہ × 1
  13. نبیل

    نبیل محفلین

    مراسلے:
    16,612
    جھنڈا:
    Germany
    موڈ:
    Depressed
    ہمم۔۔
    کیا اپڈیٹ کمانڈ رن کرنے سے روبی لینگویج کا ورژن اپڈیٹ ہو جائے گا؟ اور کیا جِٹ بھی انسٹال کر لینا چاہیے؟
     
    • پسندیدہ پسندیدہ × 1
  14. ابن سعید

    ابن سعید خادم

    مراسلے:
    60,116
    نبیل بھائی --system سوئچ اسی لئے لگایا گیا ہے تاکہ جتنے بھی جیم ہیں سارے اپڈیٹ ہو جائیں۔

    ویسے آپ چاہیں تو gem update ruby بھی آزما سکتے ہیں۔

    اور کمانڈ لائن سے ورژن چیک کرنے کے لئے ruby -v اور rails -v نیز gem -v کمانڈ دے سکتے ہیں۔

    غالباً جیم کا 1۔3۔1 ورژن ان دنوں عام استعمال میں ہے۔ اور ریلس کا حالیہ ورژن اس سے پرانے جیم کے ساتھ کام نہیں کرتا۔
     
    • پسندیدہ پسندیدہ × 1
  15. نبیل

    نبیل محفلین

    مراسلے:
    16,612
    جھنڈا:
    Germany
    موڈ:
    Depressed
    شکریہ ابن سعید، اور جِٹ کے بارے میں بھی کچھ بتائیں۔
     
  16. ابن سعید

    ابن سعید خادم

    مراسلے:
    60,116
    git کو ابھی موضوع بحث لانا قبل از وقت ہوگا۔ کیوں کہ اس کا ریلس یا روبی سے سیدھے کوئی تعلق نہیں۔ ہاں یہ ایک ورژن سسٹم ہے۔ مثلاً سی وی ایس یا ایس وی این جیسا۔ اس کی امتیازی خصوصیت یہ ہے کہ اس میں لوکل ریپازیٹری بھی ہوتی ہے۔ یعنی آپ جتنے ورثن چاہیں اپنے لوکل ورکنگ کاپی کے بنا سکتے ہیں اپنی لوکل مشین پر ہی اور یہ تبدیلیاں سینٹرل ریپازیتری میں تب تک نہیں جائیں گی جب تک آپ گٹ پش نہیں کریں گے۔ انھیں خصوصیات کے باعث یہ بہت تیزی سے مقبولیت پا رہا ہے۔

    اس کا بہتر استعمال ڈسٹریبیوٹیڈ انوائرنمینٹ میں کولیبوریٹیو ڈیویلپمینٹ کے لئے انتہائی موزوں ہے۔

    github اس سال کے بہترین پروجیکٹس میں نامزد ہوئی ہے۔ یہ سائٹ مفت اور کامرشیل ہر قسم کی گٹ ریپازیٹری سسٹم مہیا کراتی ہے۔ مزید تفصیلات کے لئے اس کا ہوم پیج دیکھیں۔ گٹ ریپازیٹری سسٹم یوں تو ریلس ڈیویلپر یا یوں کہیں ایجائل ڈیویلپمینٹ کی دنیا میں ویسے بھی خاصی پزیرائی حاصل کر رہی ہے۔ اس لحاظ سے میں اس کورس کے اختتام کے بعد ریگولر بنیاد پر ارسال کئے جانے والے ٹپس اینڈ ٹرکس میں کبھی اس کا ذکر ضرور کروں گا۔ ویسے اس کے لئے کافی اچھے رسورس میری نظروں سے گزر چکے ہیں میں انھیں بھی وقت آنے پر سامنے لاؤں گا ان شاء اللہ۔
     
    • پسندیدہ پسندیدہ × 1
  17. باذوق

    باذوق محفلین

    مراسلے:
    1,093
    کہیں اس طرح لکچر کے دوران ونڈوز صارفین کو مشکل تو نہیں پیش آئے گی؟؟ کیونکہ میں تو ابھی لینکس کی طرف منتقل نہیں ہوا ہوں۔ گھر اور آفس دونوں جگہ ونڈوز ہی ہے۔
     
    • پسندیدہ پسندیدہ × 1
  18. ابن سعید

    ابن سعید خادم

    مراسلے:
    60,116
    نہیں قطعی دقت پیش نہیں آئے گی۔ آپ پریشان نہ ہوں۔ میرے پاس دوسرے طریقے بھی ہیں جن کو کورس کا خیال آنے کے وقت سے دماغ میں رکھا ہے۔ تھوڑا سا سسپینس رہنے دیجئے ابھی۔ :grin:
     
    • پسندیدہ پسندیدہ × 2
  19. دوست

    دوست محفلین

    مراسلے:
    12,952
    جھنڈا:
    Germany
    موڈ:
    Fine
    میں تو دونوں جگہ چلاؤں گا انشاءاللہ۔
     
    • پسندیدہ پسندیدہ × 1
  20. ابن سعید

    ابن سعید خادم

    مراسلے:
    60,116
    میں منتظر ہوں کہ کچھ اور لوگ آ جائیں تو سبھی کو ہروکو اکاؤنٹ بنوا دوں۔ تاکہ کسی کو سیٹ اپ کے لئے پریشان نہ ہونا پڑے۔
     

اس صفحے کی تشہیر